Baofeng DM-X DMR

I am using Micro usb, looks like it shows no printer connected,.

Thank you

73’s
2e0GFU

Cant seem to find it at all on Device Manager.

Unfortunatelly my windows 10 is not englisch version, so a screen shot may not help you.
Just maybe a silly question, after you try to read from ready, you press the OK button ? Does the message appear “Please check all connections and communication port setting.” ?

Bildschirmfoto vom 2020-11-18 19-09-58

After I connect my device and power on the device it works on mine.

73
DC6RD

What is the current radio firmware please ?

My firmware version in the Baofeng device as “Radio Info” is V02.02.022
When I read in the MD-Programm is says: DM-1702-V1.4
I can send you the pics I did, if you need.

As far as PC goes, the offending hellspawn (aka DM-X, with a MD1702 V2 sub version) my friend dumped on, got recognised enough to do the downgrade/upgrade 'brick n fix routine method of putting it onto FW 2.22 which the success stories show actually works.

But I did have to (out of desperation) put my extremely radio programming targeted WS2012 ‘workstation’ image backup onto a spare machine so any screwups would make existing nightmares any worse on main setup.

I only did that out of desperation to hopefully get the ■■■■ spawn reprogrammed and kitted with CPS software on disc and a good USB (ordinary kind) thrown in so I can dump the thing back in his direction and get some ■■■■■■ closure on what’s been a painful chapter I thought I’d left behind when I stopped working with Sony Ericsson equipment.

So it is FW programmable now, CPS accessible, GPS seems to still work ok. So I’ll whack in a short CP to radio test and if all is well, it’ll get a proper code plug once the owner gets off his ■■■ and sends me his wanted final frequencies and zoning list.

If NASA or SpaceX want a dummy payload for their next launch test, they are welcome to the discs, printouts and everything I possess about aggro devices and kill-it-to-cure-it fixes (dare I say… iPhones where owners sold them to shops leaving the icloud lock on?). ■■■■, if anyone wants a target to nuke from orbit, just give me a location and I’ll leave the stuff there (once the lockdown gets lifted).

That so-called friend would be wise to forget I exist…

@VA3NDP - Thanks for being supportive with kind words, they did help along with your suggestion about downgrading and upgrading the FW.

Oh, and I forget who asked, there is no official FW 2.23 to download unless somebody manages to backup a radio with that revision on.

■■■■, Baofeng list the radio as a 1702 variant but their support consists of a UG which like most Baofeng and other Chinese manufacturer robot translated manuals are about as useful as a battery made out of used teabags driving a starter motor.

I bet, if you could identify the SPI or internal programming port (usually SPI or JTAG), a eeprom dump would enable reverse engineering the 2.23 FW shudders at the thought of reliving those days

The dump (without bootoader itself) should be quite easy from bootloader mode (black screen), no need to go SPI route. But reverse-engineering to something useful is probably not possible, there are thousands of functions in code (which uses an RTOS core). Also, you have to dump memory from the CPU itself, EEPROM contains only data, not the code.

@pm_cz - clearly it’s not always a case of circuit sniffing and using board level ports to extract eeprom contents from, but it’s still a tool approach you can end up needing when other software extraction and reversal approaches fail.

I’m still bearing the mental scars of reverse engineering out of absolute necessity not just for hobby interest, so I’m under no illusion how difficult it can be, so much so it makes imaging and cracking an encrypted image look easy by comparison.

I’m actually beginning to suspect this whole unofficial firmware version was either part of an abandoned venture or suchlike - it could be somewhere towards explaining why DM-X’s exist but nobody commercially acknowledges them or touches them. It’s like a rebranding destined for a market where somebody was trying to create a locked down manner where you’d be forced to use a specific expensive variant CPS that never appeared.

OK, just a few clarifications:

  • there is a Python2/3 tool created last summer I have linked earlier in this forum, which accesses the file system of the EEPROM and can modify the boot image (last I have tested it was with FW .22). It can also read the flash of the radio excluding first blocks with the bootloader which are not accessible (I had a modded firmware just for me which did this, but it was using a patch to some functions which accessed the memory to not break anything in normal communication protocol and had limited memory access). So to make it clear, it will dump the whole firmware image. And yes, I did reverse-engineer most of the communication protocol sniffig the USB bus.
  • The .23 firmware source may be a dump of RT72 radio from Retevis, which uses the same SW/HW combination, but it might not. Unless someone dumps it in the firmware update mode (black screen) we cannot be sure (but the HW may be slightly different so say if the CPU has multiple USB ports, it may be using wrong one not connected to the USB connector, but this is a speculation, I forgot in the meantime it’s exact type).
  • I have played with Ghidra and the FW last year, so I know quite a lot about the organization of the FW, but not enough to modify it. I gave up on it.
  • The EEPROM memory layout for CPS is “strange”, blocks are identified by an ID in the end of them and they do not have a fixed position in memory (but boot image is in a different block)
  • And yes, there is a special set of bytes written in a block between bootloader and FW, which contains a code based on CPU ID which is checked in firmware to prevent clonning of the device. But it would just prevent the device from working.

Well, since the tools now exist, there’s scope for a lot of stuff. But that’s for those who have the time and motivation, both of which I sorely lack having other engineering stuff on the go and trying to fit in resurrecting my ancient defunct trunking system design for modern types of protocols.

But irrespective of why a seemingly unofficial f/w appeared on the later units particularly and the fact Baofeng and actual manufacturer treats them as virtually nonexistent leads to another possibility behind their mystery nature.

Are DM-X’s merely near-Chinese copies of the DM1702 GPS variant?

If they are and haven’t subsequently been certified specifically, instead using any existing DM1702 certification status falsely, it opens up a whole stinking barrel of rotting fish for those who bought in the interests of regular DMR T2 intended legit licensed use.

Clearly it’s not an issue for ham users as we don’t need worry as in our allocations use, it’s clear sailing. But I do give a ■■■■ about those who unwilling fall victim to such trickery much like what happened over W305/R700 hybrid ‘DMR’ UHF equipped cellphones.

hi everyone,
i have been reading this thread with great interest,

i recently had the misfortune of buying a dm1702 gps before stumbling on this forum…

i received my radio yesterday and 1, the language was set to chinese… and 2 the channels have been named (channel 1) which as i have read here renders the unit unable to be put into vfo mode, now trying to connect to my pc to get into programming software and the unit does not even recognise the usb has been connected, i mean nothing on the pc or the radio…
so other than editing the channel 1 on the radio my unit is a shiney new brick…

any help with either getting into vfo mode or getting this shiney new brick to register to my pc would be a huge help
cheers all

Are you able to see if the firmware in the radio ends in .23? If it does, that’s your issue. I just went through the exact same issue. I had to downgrade to .22 and all worked great after that.

Yes, default language is Chinese. VFO mode can be activated by holding right button bellow display ( ___| ) for several seconds but ONLY IF the radio is in frequency display mode not the channel name display mode. Everything about that has been discussed earlier in this topic several times, please use search function for finding details.

For USB communication, use micro USB cable (with longer metal part) but NOT the USB cable for NON-DMR Baofengs, which uses different communication. But as was mentioned above me, if you have firmware version ending .023, there is a connectivity issue which can be solved by putting radio into firmware download mode and downgrading the firmware (but you won’t be able to get CSV contacts). Or try to ask the seller for correct CPS/fimware.

my firmware is the 02 version which is why im stumped with this,
the channel has been named which is why i cannot get into vfo mode and programming is needed to change this

i will try a usb lead with a longer connector as you have mentioned thanks for that one but i wont hold my breath

The firmware is always version 2, what we are talking about is the end section of version. When you go to Menu->settings->Radio Info-> VerSions you will see V02.02.0XY and we are talking about the XY being 23. So what is your value there?

EDIT: Now I am really confused, I have flashed FW 2.2.23 extracted from my RT72 to DM-X to simulate your issues and it works without any problem with old 1.0.66 and new 1.0.78 CPS under Windows 7 in my virtual machine, plus my tools read and write data as well. HW version is MD1702-V1 for both devices.

thanks for your help all working now, turns out you tip with the longer tipped usb cable was right! i can now use the programming software and get this radio functional cheers buddy :call_me_hand:

Note - the ‘longer tipped’ micro USB cable success does not support the as-posted conclusion that different wiring/protocol/communication (what seems to be meant) are involved.

Micro USB cables are standard wiring, either for data and power/charge (also permitting host-powering of attached devices) or power only intended as charge/power cables. The only tangible difference, between 'long tipped as described and regular micro USB connectors is how far the insulation (the bulky moulded bit the connector sits in) extends length and width wise.

In most cases, pretty much standard - it’s equipment manufacturers at fault in their sloppy designs for socket housing mostly being the biggest cause of seemingly no electrical connection. On older cables, where you could slide the covers off, you could determine this easily by simple electrical testing to determine if no detection was due to a physical poor or non-connection. Doing that these days means testing (without a tester) at attached equipment socket level or very careful piercing of outer insulation and inner cable insulation which is not easy on cables that thin as a lot are these days.

But irrespective of why a so-called standard connector fails to electrically connect fully, connectivity due to physical irregularities and subsequent electrical connections failure is not the same as a protocol/non-standard type difference.

On some types of serial connections, there may be causes where the intermediate cable impedence and nominal impedance of termination can be causes of problems, but I’ve yet to see a USB example bar the obligatory infinite HR caused by a wire break or infinitely low caused by an inline short - and it’s usually an intermittent HR or persistent HR due to the actual wires not connectors.

But that all said, whoever designed micro-usb connectors should be sent to ■■■■. The connectors have near zero long term robustness and PCB mount sockets design is a very unfunny prank on us all. So much so, everything I own with micro-usb has been modded to at least make the PCB socket more stable and robust. Where possible, I’ll source non-pcb mount sockets and short wire those back to the PCB in the knowledge it’ll easily outlive the original setup robustness wise.

Mini-usb was the best sub-USB design by far, that’s what should have become the required standard power/data connection not ■■■■■■ monkey metal grade mini-usb termination we’re stuck with.

What’s the download address of Baofeng md-1702 to upgrade firmware v02.02.023

thank you

Hola, tengo un Baofeng DM-X ( DM-1702B) y como he leído en este foro, cuando se conecta con el cable USB o con el cable de dos conectores, aparece en el administrador de tareas como una impresora compatible USB, y debajo como que no hay conectada ninguna impresora. No puedo leer de la radio ni subir otro firmware. En el momento de intentar leer la radio aparece en la pantalla que hay cable usb conectado y desaparece enseguida y se ve en el administrador de tares de windows 10 que desaparece la compatibilidad con impresora. A los 2 segundos vuelve a aparecer y queda igual. La cadena como versión del fw que aparece en la radio es L05.01.004. la versión de baofeng es DM-1702B. Se agrasdece cualquier ayuda. Gracias.