Baofeng DM 1702 Programming

Hi, new to the forum and HT units. I received a Baofeng DM 1702 for Christmas. Trying to program the unit. I’ve downloaded a couple of versions of programs for the Baofeng site and a couple of others. If I can get the app to install, when I connect the 1702 to my Windows 10 computer and try to read the radio data, I get a message saying the read failed (thanks, I kind of noticed.) The screen lights and flashes the unit is in PC Program USB mode. The green indicator light on the 1702 flashes twice. When I check device drivers in Windows I see a printer device driver associated with the 1702 - it says no printer attached. Same results with a USB cable or the programming cable that came with the radio. I’m looking for any help anyone can provide. Is it possible that the unit is defective? HELLLLP Please. Thanks in advance.

It’s almost certainly Windows doing it’s thing. The first thing to do is to try it on as many computers as you can. I’ve never yet found a faulty radio - but the USB interface is endlessly random in success. For my radio programming I have got quite used to X working on one computer with another working only on a different one. Windows has a habit of really getting confused, and if it thinks the interface is a printer, it’s certainly confused. Sometimes one install of Windows 10 will constantly replace the correct driver with a non-functioning one it determines is the right one, despite you saying it’s not. The CPS for one popular radio has been known to totally refuse to work with one Windows install, and the solution was to use a totally wrong CPS, which read it and can write to it. One customer thought he’d bricked the radio and tried new firmware and all sorts of internet suggestions but I supplied another radio and it was the same. He returned both, which read perfectly well on my computers. Sadly, this is normal.

I’d certainly try every computer you can get access to - and I bet you’ll find they’ll work. The 1702 and a couple of others all use similar CPS versions - daft really, but how it is.

1 Like

Thanks for the advice Paul. I’ve tried both the 2 plug cable that came with the radio and a micro USB. I will try a different one. Also tried this on 2 different W10 computers. The right device driver is installed when I plug in either cable, but I get an error message when I attempt to READ the radio and any other options are grayed out. And daft is a good word to describe the situation. For the life of me I can’t find and english language version of the 1702 CPS program. Tried the 1701 program but no love there. Well, back to search. I feel rather Don Quixoteish.
Alan

Not sure if this is the version you already have, but give it a go - and the Chinese version has the English text version in a menu - if you use google translate and use the camera, you can find the menus and change it. https://www.eastanglianradio.com/baofeng-DM-1702.exe give it a go.

1 Like

Hi Paul. Well I don’t know either, but at this point, I did try biting the head off a live chicken, Neither the chicken nor I enjoyed the process and the result was disappointment.
I’ll load this one up and give it a try as well as trying some different cables. One never knows. I’ll let you know how I make out.
Thanks for all your support.
Alan

It’s a total pain - in the main, I blame Windows - My PC in the office with Windows 10 and latest AVG, quarantines every CPS software I install while it double check with AVG - I guess it is the writing routines in the zip file they’re normally supplied in, but my PC at home, with the same software doesn’t do it!

Fingers crossed you get there! Paul

1 Like

Well I have tried it on two different W10 machines. My laptop has AVG on it and it does make it a challenge sometimes. I appreciate the attempt to protect me from myself, but really! My wife’s desktop has little anti-anything software on it and we get the same errors and results.
So, I downloaded your file, so full of hope - angels sing, things like that! Program loaded up fine, I think, you’ll see my reasoning in a minute. I plug in the radio, turn it on, look in device manager and there’s the driver. Fire up the program and click on the read radio icon and disaster ensues. Well not exactly disaster more like shattered dreams!

Not only did the program not run, but it failed me in some unknown language. Probably giving me some rude dustoff that I can’t even read.
I have one or two other things to try and if unsuccessful I’ll return this. My current replacement plan is to drop DMR and go analogue for the moment. I have my General and could go right to HF, but being a pensioner I need to save my pennies first. I have a very nice set of repeaters nearby that I can hear just fine on my Radio Shack (a name from the past. Of course I worked for Digital Equipment Corp and Compaq Computers, both names from the past) Pro-90 scanner. If I do that, I’ll go with either the BF-F8HP or the UV-82HP (I assume there is some logic in product naming, but again, I might be disappointed.
Here on the US east coast north of Boston the temp is around -3C and there’s a bit of snow about.
Thanks Paul

I think you should try a few other CPS apps from different radios and check these run. I wonder if you have something missing on your installation - and this will no doubt cause trouble with others. So many radios now assume you have a computer for programming as there are so many parameters to programme that means any of the clever radios really need the computer and something is adrift. Def something adrift here somewhere, and I bet it isn’t the software. I suspect it’s reading from the wrong port so despite having the driver, it’s trying to read from the wrong location. Paul

1 Like

Simple question, and probably not the problem but are you certain you have the correct cable? There are many variations of programming cables, and the ones for analog radios will not work with DMR radios. Is the cable specifically marked for the DMR? The analog cables have the chip in the cable itself (usually listed as a Prolific or FTDI chip) but the DMR radios have a chip in the radio itself. The programming cable for DMR is just a simple pass-through cable. Could they have sold you the wrong cable?

Once you get the correct port set up, I have found that TYT and Radioditty DMR cables work on either DMR radio. Have you tried other DMR programming cables?

There are other tips on the Baofeng DMX thread about the programming cable. (Same radio.) They suggest:

  1. Plug in your programming cable to your radio first, then plug it in to the computer’s USB port. Turn the radio on. You should see a new device detected in the “Universal Serial Bus controllers” section called “No Printer Attached”. This is to be expected and is NORMAL.
  2. Start the MD software. Click the “Read” button to the right of the “Save” button on the toolbar. NOW, THIS IS VERY IMPORTANT. A screen will appear that says “Read data from radio” but it hasn’t done it yet. Defying all logic, you must click the OK button to make it actually read the data.

Funny thing is that I fussed for over an hour before I figured out I had to click “OK” to get the download started on my TYT radio.

1 Like

Happy end of 2020!! On the cable side of things I have tried a couple of things. I did get the radio with the cable from them. When I plug this into my Windows 10 computer and turn it on, a drive, not the Prolific or FTDI driver opens and makes noise about no printer. Based on my searching around this seems to be the expected behavior. I’ve also tried a couple of micro USB cable and get the same behavior when connected.
I’ve downloaded SO MANY version of software that claims to be for DM1702B that I received a cease and desist order from my computer. For a while, I too feel victim to the lame-■■■ process to read the data from the radio. Once I figured that out, I’ve never been able to get past clicking on OK and getting an error message. It is interesting that the screen on the radio does popup a transient message about being in PC programming mode, but it seems to get over that quickly.
I’ll work with this some more over the weekend. In the meantime I’ve ordered an analogue radio that I should be able to program with CHIRP.
Thanks for your offer to help. This has been an “interesting” process so far and it far from over.
Alan

Not once have I plugged the cable for any radio in and had a driver window open and mention a printer - ever? If you cover the cost of postage, I’d happily see if I can programme it if it will help you. I’ve got some Baofengs in the store - currently 1801 and 760’s but the offer is there if it’s driving you mad. I really think this is a computer issue, not a cable or radio issue.

1 Like

Hi Paul, well Happy New Year. Just took a look at your website. Looks like you have a great business. I appreciate all your support. The idea of shipping the 1702b to you in the UK and having it sent back is interesting, but I suspect the cost of the shipping will be more than the cost of the unit.
So, accepting reality I’ve decided to declare victory, I’ve redefined the meaning of victory, and move smartly off the field of battle. I’ve ordered a triband UV5 and am returning the miscreant 1702B to Amazon. The new radio should be here on Wednesday next and I’m hoping that 2021 will serve me better than this year has.
Thanks again
Alan

Well, you asked for my opinion. (Maybe not … but you get it anyway. LOL) I think it’s time to get away from those cheaper eBay - type radios, and order from a REAL dealer. (Our forum hosts buytwowayradios is one of the BEST.)

I would HIGHLY recommend you get a tri-band radio that is good quality and has Chirp software support. Trust me; you will thank me in the morning. They are not $29 radios, but are many many times better. I have tested a LOT of radios, and the ones that meet your criteria of tri-band, plus are supported by Chirp, are the new TYT TH-350 and the Wouxun KG-UV8E. I have similar models of both (TYT TH-UV8200, Wouxun KG-UV9D) and they are excellent. The TYT is well-built and it sounds head and shoulders better than any Baofeng ever made (except maybe the UV-82C.) But out of everything I own, the Wouxun UV9D is still the best-sounding radio I own and it picks up better than anything.

Yes, they are not cheap, but they are worth it. Programming is easy, and I can save you a ton of money right now. It’s simple - don’t spend a DIME on any aftermarket antenna. I have never found one that was better than the factory, in spite of all the online reviews to the contrary.

1 Like

Well, if I did not want opinions I would not have posted here. :wink: Advice of course, but opinions are a good thing. I’ll take a look at buytwowayradios as you recommended. I was looking at triband because one the fairly active repeaters I have been monitoring is in the 220 Mhz range.
Thanks
Happy New Year

Before you send it back, I have had a thought. About 3 am, actually. I’ve not had a 1702, but I wonder if the problem is the programming cable. Baofeng are using a plain cable in some of their radios, but not all - as in the chip that was inside the oversize usb connector is now inside the radio, so if you have the cable with the old chip in the plug … it wont work. Or of course the other way around where the radio does not have the chip, but neither does the cable. Your strange messages started me thinking about something odd with drivers. I think something you said earlier had made me think you were in the Uk, so the post idea is a bit silly! My guess is that your cable has the longer connector with chip, and your radio doesn’t need it. The other Baofengs I have do not need the cable with chip in, maybe the 1702 is the same, but you dont have the right cable? Maybe? Hopefully?

1 Like

Happy New Year to you, too. Wouxun is much better quality than Baofeng. Just for fun, I tried solving my one tiny irritant I have with the UV9D. I like to be able to read the screen even without transmitting or pushing any buttons. Due to the nature of the screens on radios such as the TYTs and the UV8 and UV9 series, they are very hard to read after the display times out. Just for fun, I set my UV9D display to stay on constantly and tuned to a busy UHF frequency. I found battery power lasted virtually as long (2 days +) with the screen on constantly as it did with it dimming after 30 seconds with every transmission. Wouxuns will also use a certain amount of battery power when off, but that never became an issue with me.

Interesting that I have not found any DMR tri-band handheld radios, but if you find that a lot of repeaters in your area are moving to DMR, maybe look at the TYT MD-UV380. Tons of support for this model, and as I said previously, it has great audio. (Programming is not easy if you are new to DMR, and there is no Chirp support for DMR as of yet.)

So, the ultimate question if you are going to spend a few extra dollars - DMR dual-band, or analog tri-band? If you ask anyone on the forum, they would almost always say, get them both. You are going to end up with both anyway. No one buys one radio. (It’s an addiction. I know.)

And I will repeat my advice about handheld antennas. Ignore all the online reviews and stick to the factory antennas, especially with tri-band. I have tried virtually all the dual band antennas - including custom-tuned ones - on the market in head-to-head testing, and few worked better than factory and none of them lived up to their promises.

By the way, if you decide to stick with DMR and dual-band, the TYT is also licenced for Part 90 business frequencies, and a simple unlock of the radio will open up your frequency bands quickly and legally.

1 Like

So I took your advice and looked at the TYT MD-UV380. A lot to like and BTR.com looks like a solid supplier. I have the radio and programming cable in my cart to pull the trigger. Before I did, I decided to download the manual and the programming software. Installed the software and it’s not in english! Now I’m concerned. I suspect you might be able to program it without software, but I’m not sure. Do you think I can program it with CHIRP.
And, as you mentioned, I will want to come back to digital. Just maybe not with Baofeng. The low low price is an enticement, but if can’t get the freaking thing to work any price is too much.

Thanks again

Paul, it was not really my intention to keep you awake at night. Let’s see, 0300 your time is about 2200 EST. I’m located in the Boston Massachusetts area. In fact one of my kids works for the U.S. National Park Service at the Boston Historical National Park. She works on the USS Constitution and at Bunker Hill. So, NEW England, not Old England! Your question about the cable is a good one. I got the cable that was provided with the radio and I can’t tell if it has the chip or not. Since the seller included it you would hope it was right, but with some sellers that’s asking a bit much. I got my PC to notice the radio with seller supplied cable as well as a standard USB cable, but no love trying to actually connect the software to radio and read the data. At this point I think I might go analogue for now, but I want to come back to digital. It’s more interesting as a technology and I am kind of a nerd/geek. Since I’m doing ham radio I guess that’s an obvious thing.
I’ll let you know how things go.
Thanks again
Alan

You will like the radio. I wish you had also followed my advice about buying from a real radio dealer like buytwowayradios though! (You should remove the link to that other website on your post though. Only fair, as buytwowayradios owns this forum, and provides us this venue for free.)

Both buytwowayradios and TYT have the appropriate software on their websites. Easy to find. (Google TYT software, and it will steer you to the correct site. Scroll down to the latest CPS, under 2019-01-7. It is labelled UV-380-390 for USA.)

You may also need a new USB driver for the TYT cable. Install that after you install the CPS (customer programming software) which is now version 1.10 or 1.12. (Version 1.03 works just fine.)

Please do NOT download or use any upgraded firmware quite yet. Let’s get the radio programmed first! Then, you can look at some of the latest firmware updates.

There is lots of information available on this radio. One thing you will need to know is your firmware version. In Menu, go to Utilities>Radio Info>Radio Versions to find your firmware version.

If your firmware version is 14.07 or higher, you are good to go for now.

Newer versions of this radio come from China locked into bands 150-160 MHz and 450 to 460 MHz. There is no reason for this as the radio is approved for Part 90. To unlock the radio, do this:

  • Turn the radio off.
  • Hold down side buttons 1 and 2. (The two buttons adjacent to the PTT.)
  • Turn the radio on while holding down these buttons.

It will now be unlocked to the full spectrum of 136 to 174 MHz VHF and 400 to 480 MHz UHF Frequencies.

Before you try programming anything, read from the radio first. Save this file as the factory default. (Don’t do my mistake and neglect to click the OK box to upload or download programming!)

If you are new to DMR, I would suggest simply programming a couple of simplex analog frequencies first and see how it works. Good luck, and remember you cannot brick this radio. Experiment with it (half the fun) and work through the programming.

1 Like

OK, I Googled the software and found UV-380-390 USA for 2019-01-7. Now next (time to display my monumental lack of knowledge. There are separate CPS version for the 380 and the 390. Though I don’t have the radio I installed the 380 version and lo and behold, it is for the most part in English.
Now the question, do I want the 380 or the 390 version or perhaps it’s a don’t care. This is the 350 radio after all.
Hey, at least I think I’m making progress. The radio should be here, Boston area, Wednesday.
Thanks for the help.