Wouxan KG-UV9P not selecting channels

I recently purchased this radio and I’m still getting used to it, but I’m thinking it may be defective. No matter what I try, I can’t get it to select individual channels (I programed a dozen channels in using software) I found these instructions but nothing seems to help. I also can not manually type in frequencies. It appears in screen for a few seconds then defaults to what was there previously

“Step 2. Press and hold [TDR] for two seconds and enter Frequency Mode”

It doesn’t put my radio into frequency mode and no matter what I do, I can’t get any control over channels, I can only change frequencies with knobs or arrow buttons. I tried everything I can think of and even did a reset, but nothing allows me to select channels. Any ideas if maybe I’m doing something wrong or maybe I have a defective radio?

Can’t really answer this question without knowing more information. Was this a new radio or a used one? Did you buy it from a recognized dealer or from a place like eBay? What frequencies are you trying to program into the radio? What software are you using? What cable are you using to communicate with the radio? Have you talked to the radio dealer/seller?

I am assuming you are trying to program amateur (ham) frequencies, and that you know this radio is locked to the following amateur frequencies only:

RECEIVE

  • 137-174MHz VHF
  • 400-512MHz UHF

TRANSMIT and RECEIVE

  • 144-148MHz
  • 420-450MHz

If you are trying to enter frequencies outside the amateur radio spectrum (above) it will not accept.

It was purchased new, from and authorized dealer. I only received it yesterday so I’m hoping to hear from the merchant tomorrow. I also purchased the USB cable from them and used the Chirp software. Some of the channels I programed were a few emergency channels that I know are active (but I have no way of accessing them in the radio)

I was able to get some frequencies entered, but not the range you posted above. I was able to enter 144-145 range and 430-439. Nothing else would work. Should any of them be working if they are locked? I tried entering some local repeaters, like 147.09000 and 444.40000 but they don’t enter. I’m sure 90% of this is my fault, but I don’t understand why

I’ve had it scanning for hours, between the only frequencies it would take 144-145 & 430-439 and have yet to hear anything

Also all of my menu buttons seem to be working, all but CH-NAME (menu item #29) When I try to select it, it just jumps out of the menu all together, which leads me to believe it is defective and why I can manually select a channel

Without using that specific set, but having programmed a KG-UV9K using the god awful wouxan software -

Exactly what ranges you can enter and subsequently manual tune to and subsequently program in via software or (in the case of the D and K variants) by keypad /menu and store depends on if it’s an export model.

The differences are outlined for each variant and sub-variant on the Wouxan site, so I’ll skip outlining the model specific UV-9 series variants and refer you the website and user guides (ironically, the UG’s are almost like the author actually spoke English).

As for not hearing anything on frequencies you have set /dialled in (variant dependent), there’s three main causes of absolute muted silence (assuming the volume isn’t at 0) -

  1. There’s either no traffic on the frequency that’s got a signal level and lack of noise above the current squelch threshold - on modern FM sets, it’s a true noise squelch where the threshold is set against noise level (white noise). So a very high setting mutes out most weak/noisy traffic (as in ‘not quietened’). To determine if it’s a squelch level, either try the monitor which bypasses the squelch and let’s you hear raw what traffic or empty frequency is there, or turn your squelch down progressively until you find stuff opens the squelch. If there’s no decernable traffic, apparently an empty frequency, you’ll more or less have to set squelch to 0 or bypass to hear.

Since, in the case notably of keypad frequency entry on applicable UV’s and most Wouxan sets, if you punch in an out of range frequency, it’ll reject and remain on the last setting. Likewise, on sets with extended/wide receive, it’ll inhibit TX if a set frequency falls outside of the versions set Tx frequency ranges (which depends on variant and sub-variant). That’s why it’s better to buy from a radio outlet in your country than (as many have) some random Amazon/eBay vendor, as proper radio outlets sell an applicable variant for the country they ship to, where on cheaper sources (eBay and Amazon etc) there’s no guarantee you’ll get the export model where applicable (in fact, many such sellers don’t realise there are sub-variants and have typical box-shifter product knowledge).

Assuming there’s traffic you know is on frequency via other means, silence that’s not due to squelch muting etc, or accidental setting of the tone squelch, points to a PLL unlock state (where you’ll hear nothing on the freq dialled on) or a deaf receiver or a dodgy antenna and/or antenna connection.

PLL unlock is why you can’t TX out of band, because the invalid frequency (TX wise) set translates to an invalid BCD code and causes an error condition at the PLL known as an unlock state and TX is automatically inhibited in such a state.

That’s why since PLL synthesised radios came about, it became harder to work your of band without trickery to force the PLL by electronic trickery. Good example of such trickery being how on 27mhz, you ended up with a daughter board with original and alternative variant PLL chips feeding the original socket to get dual band out of a single band PLL radio.

Anyhow, assuming there’s no fault, and it’s a matter of software/CPS programming of channels/memories, you need to ensure you code in valid combinations and the KG Commander software admittedly isn’t that great at giving you solid clear indicators to why something is invalid.

Good evening,

I just received the same radio from But Two Way Radios online store and I also have the same challenge. What was your fix if any? I emailed the sales team for help and am waiting for a response.

Did you press tdr again to enter “channel mode”?

I just recieved my uv9p and i got to vfo mode saved a couple freq into memory but cant get back to ch mode (yes i held town tdr) also cant program freq i use due to redtricted freq range

What frequency are you trying to program? All the usual ones are within the capabilities of this radio?

Please note that programing the Wouxun radios with chirp is not supported as Chirp is a third party software. However to reenable the TDR function power off your radio and the hold the #2 button while powering it up and hold until radio comes back to operating mode.

1 Like

I figured it out… but it wouldnt allow anything above 146 mhz…i found a post on another forum that said "when pwr is off hold down #2 key as you turn on pwr…mide 2 msg will appear then release #2 key and it booted up and allowed full freq access

1 Like

John - I’m a little confused. This radio is supported by Chirp - or at least, it’s in the list. Is the 9P not programmable? That’s interesting, or is that one of the american exclusive radios that can only do ham bands? Chirp says the KG-UV9D is the model to use for the KG-UV9P?

Paul,
While someone might have written the code for it, it is not supported by Wouxun for use with chirp. I didn’t say you couldn’t use it on the radio but however if you cause damage to the radio because of it, Wouxun will not honor any warrantee. Also when you use chirp a message about the software pops up warning you that use of it may have an unwanted outcome.

I didn’t think very many manufacturers liked chirp very much, but quite a few now sell you a radio then release firmware updates that can be far more destructive if they go wrong. Kydera, for example have a very active forum where the manufacturer’s rep joins in and actually posts various tweaks and upgrades for people to experiment with - including one where you actually install the firmware for a totally different radio to get extra features - for of public beta testing. The forum folk love it. I think that does them as a brand a lot of good. Paul