tyt 9600 firmware

how can i find out what fermware is in my radio and how can i change it

i have 2 tyt 9600 1 with firmware 6.003 10000 contacts
next one i bought ebay has firmware 4.002 will not do contacts at all
i would like to up the firmware to 6.003 0r more
i cant get to firmware with push orange button and p1 button and power button
i have the loader software in my computer
don kx3dm

There is an article on our blog with instructions on how to upgrade the firmware on the TYT MD-9600. Although the article is a little dated with an older firmware version, the instructions are basically the same.

tryed it 9600 would not go in to frimware load


I tried to install the firmware from March 22, 2018. Now I can not read anything on the display. Only gray lines. Which file xy.bin are needed for an update?
Now I want to do a factory reset, but have problems with the manual.
Have the following instructions for a factory reset found. But have problems to locate the key “LEFT (LOW)”.

  1. Turn the radio off
  2. Press and hold the LEFT(LOW) Key while the radio turn on.
  3. Rotatethe DIAL to select the resetting menu.
    F1 SETMODE RESET (Reset the menu settings to their factory defaults)
    F2 HYPER RESET (Clears the Hyper Memory settings to factory default)
    F3 MEMORY RESET (Clears the regular Memory setting to factory default)
    F4 ALL RESET (Clears all the Memorises and other setting to factory Default)

To point 2: which button on the MD-9600 is meant by “LEFT(LOW)”?
Which firmware and which CPS 1.1x or 1.2x work together.

who can help me.

To go into programming mode. first kill the power at the power supply, not the radio power button. Next push and hold the orange button and the PF1 together then turn the power supply back on.

This is the only way I have found to enter programming mode.

The radio was locking up when in DMR and worked ok analog found that scan pul down need to be turned off. My tyt 2017 worked ok with this on just not the 9600.

I was wrong in post it fixed radio temp. The radio was sold marked GPS and that firmware was the cause of problem. Flashed radio with non gps firmware and lockup problem is gone. I purchased a used radio on ebay with non GPS and it is working good too.