Baofeng DM-X problems

Well I have spent many hours trying to make this DM-X radio work. Spent most of the day just getting it to talk to the PC. Couldn’t figure out the USB printer device that showed up. Finally installed the software for the 1702 and got it to talking to the PC but that is about all the talking it will do,

With a known working hotspot is does not receive anything. When I try to transmit I get a “BS Act timeout” within 1 second of keying the radio. Very annoying.

If anyone could point me in the right direction I would be most grateful.

I really hate to have to send this sucker back for a refund if there is anyway to make it work.

I really think this radio needs to be flashed with a working bin file. I tried downloading the flashes on this site and they were not bin files, they were codeplug files. When I tried to load them nothing shows up in the flash tool. If anyone with a working DM-X that can help me out I would appreciate it.

Thanks in advance!


Well I finally got it working. Something so simple, I turned on talk around and it started working, Made a few contacts and got excellent audio reports,

Rule #1 use the micro usb cable,
Rule #2 use the MD programming software, it is the only one I found that doesn’t have a com port setting,

1 Like

I can help you my Friend

I’m not sure if your hotspot is duplex configured or not, which are split-frequency repeater style setups as you’ll know.

But I can see why the bypass would solve the problem, as chances are most would set up their split-frequency code plug entries as Repeater mode operation, out of habit I guess (been there).

But given that what duplex on a hotspot really means is half duplex split frequency simplex, you’d want to configure the code plug entries as that. In CPS it’s a pain, worse still if manually entering on a set.

Thankfully, a lot of CPS will treat CSV imports verbatim as far as programmed settings go, so I initially create individual CP entries for hotspots as repeater entries and in the CVS, alter the setting of one to for split frequency half-duplex simplex and import that channel CSV back into my code plug.

Clearly if you’re handcrafting the CVS, you can initially set it up by default to employ the actual desired settings for the HS channel presets.

I never actually got the duplex mode to really work on my HS. The only time duplex spec HD use ever really did anything beneficial was when I tested two different modes on two different sets to gateway access (DMR on my kit and C4FM/YSF on a loan radio).

But even then, you’ll spend more time (regardless of combos of radios and types used as clients/stations) more time in ‘expert’ or full edit config modes (Pi-Star references) or directly in files via nano over SSH (pi-star).

But it’s no surprise your work around worked, and ironically, where it’s normally a commercial use function we’d never use, here it actually has a use worth noting, even if a quick workaround. But one rarely realised, so definitely worth pointing out.

I’m sure it’s not just a DM-X quirk, more a quirk of a commercial mode hangover.

Don;t get sidetracked by the lack of the com port setting - I have so many CPS apps for the radios I stock you’ll get used to some autodetecting com ports (the latest versions) vs the other versions that have the menu. Also - some of those may well indicate a port number but still autodetect in some kind of manner - I know the socket I use is com port 5, not 3 - but the software tells me it is 3, 3 is set as default and 3 works. I’ve discovered that one brand of radios I have will programme fine from my video editing computer - but not from my office computer. Both have very similar specs and both run the same version of Windows 10. It’s a mystery than really annoys. The old fall-back of XP is now hardly necessary. All I want is AVG to leave them alone while they do their thing.

As for the mystery, Paul, about with works ok on one system and not another - that reminds of the days when the first spate of super cheap serial expansion cards and USB-Serial patches/leads first started getting used. FTDI based ones pretty much worked on almost every possible arrangement of a supported OS version, but i can still recall a few cases when there were conflicts with drivers and their memory/resource use on when you casually used a highly focused PC ‘box’ (such as a an edit-suite workstation and god knows how many card and external capture and p/b video outputs that could entail, and security dongle ■■■■ that went with the territory).

Add in, with USB-Serial unit specific/brand specific cables such as we use on radio kit frequently. how there was at least two different sets of configuration units just based on how the UART presence or non-presence or one side having a UART and the other being essentially JTAG into an on-host or on-device (usually device), and we’re not even touching whether various cable were breakout compatible or not and in some cases, even so called compatibles just weren’t, and the whole USB-serial business was best avoided, just fit a serial card or three, and make up cables that did JTAG-RS232 conversion either by embedded circuitry or through an inline converter. At least, then, if you invested in good quality FTDI based cards, driver/compatibility issues relating to hardware handling were a distant nightmare - and given the signalling current of those cards were stable as anything, bad transfers due to signal losses and subsequent data corruption was rare.

In fact, despite that every manufacturer of USB based comms enabled devices quotes you shouldn’t use hubs, hanging your cables off a stable high current capable hub that had a persistent common link to a PC/MAC/etc and mostly had the breakout to leave your data transfer/prog cables and USB serial cables in general in-situ, that actually often made it so much less painless with USB, and the excess of current off the hub PSU pretty much ensured you’d never (even with line powered programming and transfer) have corruptions and halts due to too many errors and poor stability with signalling current.

I mean, you would never sanely credit adding serial functionality (by whatever means) to a PnP supporting MB and OS as being anything but straightforward, but when you are talking specialised and/or highly focused setups, it’s definately comparable to trying to roll a certain number on n six-sided dice and Lady Luck is playing with loaded dice that keep rolling 7’s.

If you recall Baycom ‘soft’ TNC use and soft modems of the era in general, how much grief did two different ‘compatible’ chipsets in USB serial adapters caused - in the case of the Baycom software, it was less about FTDI vs Prolific (in USB years, and serial card chipsets pre-USB) chipsets and more about what UART was involved. Baycom software was built around the 8 series UARTS and only full 8-series compatible UART chipsets worked with it, anything with a 16 series (the later high speed design) was a non-starter and would have you going nuts pointlessly trying to fix - back in the days when most of us relied on BBS’s, sneaker net distribution of patches and independent software releases.

I’m pretty safe to assume you remember those days and that kind of grief and when trying to use your plug-n-play certified serial expansion card was never a happy time, unless it was a more expensive unit that still had jumper overrides and could be non-pnp configured.

That’s a hard learnt set of lessons i never forgot. Give me three wires and RS232 and xon/xoff handshaking and the functional equiv with other RS standard serial links, and i go prematurely bald a lot slower. I’d rather it took forever and worked, than turbo-charged squirrel on an energy drink high super fast transfers i have to do a watched kettle impression with and see it go to ■■■■ just as the job was nearly done and brick the equipment or the transfer once demuxed on device screws up and corrupts everything because a few bad packets.

But i’m pretty sure a lot of that is territory you also ventured into and had your own set of nightmares with.

helpme my radio Boafeng DMX don´t Read, i can´t not programing, my email or