Two Way Radio Forum  

Go Back   Two Way Radio Forum > Two Way Radios > CB Radios

Click here to visit our ecommerce site - BuyTwoWayRadios.com

Reply
 
Thread Tools Display Modes
  #1  
Old 09-03-2016, 11:35 PM
Dice55 Dice55 is offline
Junior Member
 
Join Date: Sep 2016
Posts: 2
Default Royce 619 troubleshooting needed

I own a Royce 619 40 channel from the 70's. It lights up but only gives off a low level static. It has no receive and no transmit, when mic is keyed TX light comes on but no output. The thing is Its new, It sat in the box for 40+ years on a shelf. I tried testing it on a good working system so I know it's the radio. Any ideas or someone who still repairs?
Thanks
Reply With Quote
  #2  
Old 11-14-2016, 11:38 AM
AMStationEngineer AMStationEngineer is offline
Junior Member
 
Join Date: Oct 2016
Location: Central PA/ North Central PA
Posts: 4
Default Re: Royce 619 troubleshooting needed

Royce manufactured what I would consider to be a "middle of the road", but good quality transceiver.

I'd suspect any of three items to be the culprit. First, look at the solder joints on the underside of the printed circuit board, see if there are any incomplete joints, or solder bridges. Second, look for leakage around all electrolytic capacitors, and plan on replacing all of them. Third, I'd troubleshoot the power supply, then the RF-in and RF-out sections which junction with the antenna connection.

Also look to see that the chassis grounds are intact.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:43 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2018, Cricket Ventures LLC